Friday, April 25, 2014

Simulasi Network Routing EIGRP di GNS3 (Part 3)

Pada percobaan sebelumnya, sudah disimulasikan redistribution connected di hampir semua router (R-MKS-1, R-MTR-2, dan R-SBY-3). Dan juga sudah dibuat redistribution static di Router R-JKT-0. Sekarang akan dicoba disimulasikan redistribution dengan EIGRP lainnya. 
network simulasi redistribution eigrp

Network simulasi seperti pada gambar di atas, dimana ditambahkan satu buah router R-JKT-5 dan satu buah user (Qmu Linux). Router R-JKT-5 menggunakan routing EIGRP dengan nomor AS yang berbeda. Berikut table IP address semua router selengkapnya.

Table IP address router
 Router
Fa0/0
Fa0/1
Fa1/0
Fa1/1
Fa1/2
R-JKT-0
200.0.10.1/30
200.0.30.1/30
200.0.40.1/30
200.0.20.1/30
200.0.50.1/30
R-MKS-1
200.0.10.2/30
200.0.21.2/30
192.0.1.1/24
-

R-MTR-2
200.0.32.1/30
200.0.21.1/30
192.0.2.1/24
200.0.20.2/30

R-SBY-3
200.0.32.2/30
200.0.30.2/30
192.0.3.1/24


R-JKT-4
200.0.40.2/30
192.0.4.1/30



R-JKT-5
200.0.50.2/30
192.0.5.1/30




Table IP address users
 Users
IP Address
Netmask
Gateway
XP
192.0.4.2/30
255.255.255.252
192.0.4.1
COM-1
192.0.1.2/24
255.255.255.0
192.0.1.1
COM-2
192.0.2.2/24
255.255.255.0
192.0.2.1
COM-3
192.0.3.2/24
255.255.255.0
192.0.3.1
Qemu Linux
192.0.5.2/30
255.255.255.252
192.0.5.1

Dari table di atas seharusnya sudah jelas, mengenai IP addressnya. Pada router R-JKT-0 ada penambahan interface (fa1/2) untuk bisa connect dengan R-JKT-5. Ok. Langsung saja konfigurasi terhadap router yang berhubungan dengan simulasi ini, yaitu router R-JKT-0 dan router R-JKT-5. Konfigurasi yang diperlihatkan di bawah ini hanyalah konfigurasi penambahan dan perubahannya saja. Beberapa konfigurasi yang sama tidak ditampilkan disini, karena sudah dibahas pada posting sebelumnya. Lihat posting sebelumnya. 

Konfigurasi Router R-JKT-0
R-JKT-0#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R-JKT-0(config)#inter fa1/2
R-JKT-0(config-if)#des P2P WAN R-JKT-0 TO R-JKT-5
R-JKT-0(config-if)#ip address 200.0.50.1 255.255.255.252

% IP addresses may not be configured on L2 links.

R-JKT-0(config-if)#no switchport
R-JKT-0(config-if)#ip address 200.0.50.1 255.255.255.252
R-JKT-0(config-if)#no shut
R-JKT-0(config-if)#duplex full
Duplex will not be set until speed is set to non-auto value
R-JKT-0(config-if)#speed 100
R-JKT-0(config-if)#duplex full
R-JKT-0(config-if)#do wr
Building configuration...
[OK]


Konfigurasi Router R-JKT-5
R-JKT-5#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R-JKT-5(config)#inter fa0/0
R-JKT-5(config-if)#ip address 200.0.50.2 255.255.255.252
R-JKT-5(config-if)#des P2P WAN R-JKT-5 TO R-JKT-0
R-JKT-5(config-if)#no shut
R-JKT-5(config-if)#speed 100
R-JKT-5(config-if)#full-duplex
R-JKT-5(config-if)#inter fa0/1
R-JKT-5(config-if)#ip address 192.0.5.1 255.255.255.252
R-JKT-5(config-if)#des LAN R-JKT-5
R-JKT-5(config-if)#no shut
R-JKT-5(config-if)#speed 100
R-JKT-5(config-if)#full-duplex
R-JKT-5(config-if)#do wr
Building configuration...
[OK]

Konfigurasi Routing Router R-JKT-5
R-JKT-5(config)#router eigrp 50
R-JKT-5(config-router)#network 192.0.5.0 0.0.0.3
R-JKT-5(config-router)#netw 200.0.50.0 0.0.0.3
R-JKT-5(config-router)#no auto-summary

Konfigurasi Routing Router R-JKT-0
R-JKT-0(config)#router eigrp 50
R-JKT-0(config-router)#netwo 200.0.50.0 0.0.0.3
R-JKT-0(config-router)#
*Mar  1 00:11:31.275: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 200.0.50.2 (FastEthernet1/2) is up: new adjacency
R-JKT-0(config-router)#redistribute eigrp 10
R-JKT-0(config-router)#no auto-summary
R-JKT-0(config-router)#router eigrp 10
R-JKT-0(config-router)#redistribute eigrp 50
R-JKT-0(config-router)#do wr
Building configuration...
[OK]

Selesai... Tidak perlu saya jelaskan tentang konfigurasi di atas. Karena saya rasa anda sudah tahu semua. Ini sudah pernah dijelaskan di posting sebelum-sebelumnya. Dan ingat... konfigurasi routing di atas hanyalah penambahan dari konfigurasi routing sebelumnya. Hasilnya, pada router R-JKT-5 seharusnya sudah bisa menerima list routing semua network. Langsung saja dicek dengan perintah “sh ip route”.

R-JKT-5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.0.21.0/30 is subnetted, 1 subnets
D EX    200.0.21.0 [170/2567680] via 200.0.50.1, 00:01:19, FastEthernet0/0
     200.0.20.0/30 is subnetted, 1 subnets
D EX    200.0.20.0 [170/2565120] via 200.0.50.1, 00:01:19, FastEthernet0/0
     200.0.50.0/30 is subnetted, 1 subnets
C       200.0.50.0 is directly connected, FastEthernet0/0
     200.0.32.0/30 is subnetted, 1 subnets
D EX    200.0.32.0 [170/1700608] via 200.0.50.1, 00:01:19, FastEthernet0/0
     192.0.5.0/30 is subnetted, 1 subnets
C       192.0.5.0 is directly connected, FastEthernet0/1
     200.0.30.0/30 is subnetted, 1 subnets
D EX    200.0.30.0 [170/1698048] via 200.0.50.1, 00:01:21, FastEthernet0/0
     200.0.10.0/30 is subnetted, 1 subnets
D EX    200.0.10.0 [170/261120] via 200.0.50.1, 00:01:23, FastEthernet0/0
D EX 192.0.2.0/24 [170/1703168] via 200.0.50.1, 00:01:23, FastEthernet0/0
D EX 192.0.3.0/24 [170/1700608] via 200.0.50.1, 00:01:23, FastEthernet0/0

R-JKT-5#ping 200.0.32.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.0.32.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/94/96 ms

EIGRP Authentication
Authentication EIGRP, yaitu metode keamanan berupa verifikasi pada routing EIGRP. Dengan kata lain, atau bahasa awamnya, ada password / kunci antar kedua router yang harus dilalui dan benar agar bisa saling berkomunikasi. Ingat... Komunikasi yang dimaksud disini adalah komunikasi EIGRP saja. Sedangkan komunikasi / update lainnya tidak ada pengaruh dengan EIGRP authentication.

Konfigurasi Router R-MTR-2
R-MTR-2>en
R-MTR-2#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R-MTR-2(config)#key chain R-MTR-2
R-MTR-2(config-keychain)# key 1
R-MTR-2(config-keychain-key)# key-string key-R-01
R-MTR-2(config-keychain-key)# inter fa0/0
R-MTR-2(config-if)#ip authentication key-chain eigrp 10 R-MTR-2
R-MTR-2(config-if)#ip authentication mode eigrp 10 md5
*Mar  1 00:19:27.159: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.2 (FastEthernet0/0) is down: keychain changed
*Mar  1 00:19:28.891: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.2 (FastEthernet0/0) is up: new adjacency
R-MTR-2(config-if)#ip authent mode eigrp 10 md5
R-MTR-2(config-if)#
*Mar  1 00:19:38.751: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.2 (FastEthernet0/0) is down: authentication mode changed

Terlihat langsung hasilnya. Ada pesan error, “Neighbor 200.0.32.2 (FastEthernet0/0) is down: authentication mode changed”. Artinya, routing EIGRP antara R-MTR-2 dan R-SBY, tidak bisa establish. Bisa juga dicek dengan perintah “sh ip eigrp neighbor”.
R-SBY-3# sh ip eigrp ne
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   200.0.30.1              Fa0/1             10 00:19:26   49   661  0  19

Konfigurasi Router R-SBY-3
So, agar bisa routing EIGRP kedua router kembali terbentuk, maka di sisi router R-SBY-3, juga perlu dicreate password atau kuncinya.
R-SBY-3>en
R-SBY-3#confi ter
Enter configuration commands, one per line.  End with CNTL/Z.
R-SBY-3(config)#key chain R-SBY-3
R-SBY-3(config-keychain)#ke 1
R-SBY-3(config-keychain-key)#key-string key-R-23
R-SBY-3(config-keychain-key)#inter fa0/0
R-SBY-3(config-if)#ip authen key-chain eigrp 10 R-SBY-3
R-SBY-3(config-if)#ip authentication mode eigrp 10 md5
*Mar  1 00:06:46.323: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.1 (FastEthernet0/0) is up: new adjacency

Yup, berhasil, langsung ada message, “Neighbor 200.0.32.1 (FastEthernet0/0) is up: new adjacency”.Dan untuk meyakinkan lagi, gunakan kembali command “sh ip eigrp neighbor”.
R-SBY-3#sh ip eigrp neig
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   200.0.32.1              Fa0/0             11 00:01:39   45   270  0  44
0   200.0.30.1              Fa0/1             13 00:30:49   51   306  0  20

EIGRP stub routing
Router yang menerapkan rules routing Stub EIGRP, artinya si router sebagai router yang berada di sisi terakhir (paling ujung) dalam network yang menggunakan routing EIGRP. Dengan diketahuinya sisi akhir dari routing EIGRP, ini akan mengurangi beban kerja router.

R-SBY-3#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R-SBY-3(config)#router eigrp 10
R-SBY-3(config-router)#eigrp stub ?
  connected      Do advertise connected routes
  leak-map       Allow dynamic prefixes based on the leak-map
  receive-only   Set IP-EIGRP as receive only neighbor
  redistributed  Do advertise redistributed routes
  static         Do advertise static routes
  summary        Do advertise summary routes
  <cr>
Ada beberapa opsi untuk eigrp stub. Seperti terlihat di atas, dan sudah jelas sekali penjelasannya. Silahkan dicoba-coba sendiri.

R-SBY-3(config-router)#eigrp stub
R-SBY-3(config-router)#
*Mar  1 01:19:47.215: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.30.1 (FastEthernet0/1) is down: peer info changed
*Mar  1 01:19:47.235: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.1 (FastEthernet0/0) is down: peer info changed
*Mar  1 01:19:47.907: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.30.1 (FastEthernet0/1) is up: new adjacency
*Mar  1 01:19:49.191: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 200.0.32.1 (FastEthernet0/0) is up: new adjacency

Untuk melihat beban kerja cpu dan memory pada router, bisa menggunakan perintah  show processes memory” dan “show processes cpu
R-SBY-3#show processes memory
Processor Pool Total:   46152192 Used:   14833264 Free:   31318928
      I/O Pool Total:    6291456 Used:    4444992 Free:    1846464

 PID TTY  Allocated      Freed    Holding    Getbufs    Retbufs Process
   0   0   26163168    6967292   16228140        590         63 *Init*
   0   0      12052     119548      12052          0          0 *Sched*
   0   0    1810740    2865404      78068          0          0 *Dead*
   1   0       5052          0      12024          0          0 Chunk Manager
   2   0        196        196       3972          0          0 Load Meter
   3   0        176          0       7160          0          0 CEF Scanner
   4   0      65588          0      90560          0          0 EDDRI_MAIN
   5   0       3160          0      10132          0          0 Check heaps
   6   0          0          0       6972         45          0 Pool Manager

R-SBY-3#show processes cpu
CPU utilization for five seconds: 4%/0%; one minute: 2%; five minutes: 2%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   1           0         4          0  0.00%  0.00%  0.00%   0 Chunk Manager
   2        2892       839       3446  0.08%  0.07%  0.08%   0 Load Meter
   3          44       144        305  0.00%  0.00%  0.00%   0 CEF Scanner
   4           0         1          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN
   5        3824       499       7663  0.81%  0.14%  0.08%   0 Check heaps
   6           0         1          0  0.00%  0.00%  0.00%   0 Pool Manager
   7           0         2          0  0.00%  0.00%  0.00%   0 Timers
   8           0        70          0  0.00%  0.00%  0.00%   0 IPC Dynamic Cach
   9           0         1          0  0.00%  0.00%  0.00%   0 IPC Zone Manager

Agak susah melihat perbedaan beban kerja pada router, sebelum dan sesudah penggunaan stub routing. Mungkin karena simulasi networknya kurang complex. Yang terpenting seperti itu. Sementara ikut saja seperti yang dikatakan teori. :)
Dan terakhir... semoga bermanfaat...

No comments:

Post a Comment