Saturday, November 16, 2013

Simulasi Network Static Routing dengan Menggunakan Packet Tracer


Routing adalah proses penentuan arah yang terjadi pada router yang digunakan untuk meneruskan paket data ke network tujuannya.
Ada 3 jenis routing yang dikenal, yaitu:
  1. Static route – routingnya diinput secara manual pada setiap router. Bahasa awamnya, konfigurasi, untuk menuju ke network ini, harus melewati IP ini… dan seterusnya.
  2. Default route – Semua tujuan network akan diarahkan ke satu gateway (ke satu pintu)
  3. Dynamic route – Routingnya melakukan penyesuaian secara otomatis untuk informasi perubahan topologi dan traffic. Dengan kata lain, routingnya akan selalu diupdate, dan akan dipilih jalur/ jalan yang terbaik untuk sampai ke tujuan.
Kadang ada pula yang membagi routing menjadi yaitu hanya static routing dan dynamic routing. Sedangkan default routing dimasukkan ke static routing.
Pembagian dynamic routing, bisa dilihat pada gambar diagram di bawah ini.
List of Dynamic Routing Protocol

Posting kali ini hanya fokus membahas routing static. Sedangkan untuk Routing dynamic akan dibahas di lain kesempatan.

Static Routing
Seperti yang telah dijelaskan sebelumnya, Static routing, yaitu routing yang ditambahkan secara manual, pada setiap router yang ada pada network. Kelebihan dari Static routing:
  • Kerja / proses dari CPU Router tidak akan berat.
  • Tidak ada penggunaan bandwith untuk update routing antar router.
  • Keamanan (karena admin hanya menambahkan routing yang diperlukan dan sudah ditentukan saja)
Kekurangan :
  • Admin harus benar-benar mengerti secara details konfigurasi dari networknya .
  • Jika ada penambahan router atau network yang baru, admin harus kembali menambahkan konfigurasi routing staticnya di setiap router.
  • Tidak cocok untuk network scala besar.
Pada router Cisco, perintah/command untuk menambahkan routing static.
ip route [destination_network] [netmask] [next_hop_address or exitinterface]

Berikut ini adalah eksperiment  saya dengan menggunakan packet tracer untuk mensimulasi static routing. Seperti pada gambar, ada 4 buah router Cisco yang digunakan.
Simulasi network static routing

ROUTER JKT
ROUTER-SBY
ROUTER MTR
ROUTER-MLK
Fa 0/0
10.10.11.1/24
10.10.22.1/24
10.10.33.1/24
10.10.55.1/24
Fa 1/0
-
-
10.10.44.1/24
-
Comp User
Dhcp
Dhcp
Dhcp
Dhcp
Fa 4/0
192.168.1.1/30
192.168.1.2/30
192.168.3.1/30
192.168.3.2/30
Fa 5/0
-
192.168.2.1/30
192.168.2.2/30
-
Ok. Kita mulai langsung konfigurasinya, saya ambil contoh untuk Router-Mtr.

ROUTER-MTR
Router>en
Router#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host ROUTER-MTR
ROUTER-MTR(config)#inter fa0/0
ROUTER-MTR(config-if)#ip address 10.10.33.1 255.255.255.0
ROUTER-MTR(config-if)#description LAN MATARAM
ROUTER-MTR(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

ROUTER-MTR(config-if)#inter fa1/0
ROUTER-MTR(config-if)#ip add 10.10.44.1 255.255.255.0
ROUTER-MTR(config-if)#desc LAN MATARAM 2
ROUTER-MTR(config-if)#no shut

ROUTER-MTR(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

ROUTER-MTR(config-if)#inter fa4/0
ROUTER-MTR(config-if)#ip address 192.168.3.1 255.255.255.252
ROUTER-MTR(config-if)#desc WAN MATARAM TO MALUK
ROUTER-MTR(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet4/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4/0, changed state to up

ROUTER-MTR(config-if)#inter fa 5/0
ROUTER-MTR(config-if)#ip add 192.168.2.2 255.255.255.252
ROUTER-MTR(config-if)#des WAN MATARAM TO SURABAYA
ROUTER-MTR(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet5/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/0, changed state to up

ROUTER-MTR(config-if)#
ROUTER-MTR(config-if)#exit
ROUTER-MTR(config)#ip dhcp pool lanmtr1
ROUTER-MTR(dhcp-config)#network 10.10.33.0 255.255.255.0
ROUTER-MTR(dhcp-config)#default-router 10.10.33.1
ROUTER-MTR(dhcp-config)#dns-server 10.10.33.1
ROUTER-MTR(config)#ip dhcp pool lanmtr2
ROUTER-MTR(dhcp-config)#network 10.10.44.0 255.255.255.0
ROUTER-MTR(dhcp-config)#default-router 10.10.44.1
ROUTER-MTR(dhcp-config)#dns-server 10.10.44.1
Konfigurasi routing staticnya.
ROUTER-MTR(config)#ip route 10.10.55.0 255.255.255.0 fa4/0
ROUTER-MTR(config)#ip route 10.10.22.0 255.255.255.0 fa5/0
ROUTER-MTR(config)#ip route 10.10.11.0 255.255.255.0 192.168.2.1

ROUTER-MTR(config)#do wr
Building configuration...
[OK]

Untuk router yang lain, (ROUTER-JKT, ROUTER-SBY dan ROUTER-MLK ) sama cara-caranya… (bukan sama persis sampai IP addressnya juga sama ya.. tapi tentu saja IP nya disesuaikan…). Saya kira anda tahu kelanjutannya, tidak perlu saya jelaskan.
Kemudian untuk konfigurasi routing staticnya. Inti dari Command dari IP ROUTE adalah
ip route [network tujuan] [subnet mask] [ip gateway yang menuju ke tujuannya]
atau
ip route [destination network] [subnet mask] [interface yang mengarah ke tujuannya]
Misalnya pada ROUTER-SBY, tujuan  ke PC-PT 4, networknya , 10.10.55.0/24, maka harus pergi ke pintu interface fa5/0 (atau ke IP gateway yaitu 192.168.2.2), ditulisnya…
ip route 10.10.55.0 255.255.255.0 fa5/0
atau
ip route 10.10.55.0 255.255.255.0 192.168.2.2
Ok, konfigurasi detailsnya seperti di bawah ini.
ROUTER-MTR(config)#ip route 10.10.55.0 255.255.255.0 FastEthernet4/0
ROUTER-MTR(config)#ip route 10.10.22.0 255.255.255.0 FastEthernet5/0
ROUTER-MTR(config)#ip route 10.10.11.0 255.255.255.0 192.168.2.1
Untuk melihat hasil routingnya, gunakan command sh ip route.
ROUTER-MTR#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
S       10.10.11.0 [1/0] via 192.168.2.1
S       10.10.22.0 is directly connected, FastEthernet5/0
C       10.10.33.0 is directly connected, FastEthernet0/0
C       10.10.44.0 is directly connected, FastEthernet1/0
S       10.10.55.0 is directly connected, FastEthernet4/0
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet5/0
     192.168.3.0/30 is subnetted, 1 subnets
C       192.168.3.0 is directly connected, FastEthernet4/0

Selanjutnya untuk konfigurasi routing static pada router lainnya, saya kira bisa anda lakukan sendiri. O ya, satu lagi. Untuk ROUTER-JKT, karena router tersebut berada pada paling ujung network, maka bisa juga konfigurasi routingnya dijadikan routing default.
ROUTER-JKT(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet4/0
Ok. Jadi konfigurasi selengkapnya pada semua router, bisa dilihat dengan menggunakan sh run atau sh start.

ROUTER-JKT
ROUTER-JKT#sh run
Building configuration...

Current configuration : 886 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-JKT
!
!
!
!
!
ip dhcp pool lanjkt
 network 10.10.11.0 255.255.255.0
 default-router 10.10.11.1
 dns-server 10.10.11.1
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN JAKARTA
 ip address 10.10.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 description WAN JAKARTA TO SURABAYA
 ip address 192.168.1.1 255.255.255.252
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet4/0
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
End

ROUTER SURABAYA
ROUTER-SBY>en
ROUTER-SBY#sh run
Building configuration...

Current configuration : 1085 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-SBY
!
!
!
!
!
ip dhcp pool LAN-SURABAYA
 network 10.10.22.0 255.255.255.0
 default-router 10.10.22.1
 dns-server 10.10.22.1
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN SURABAYA
 ip address 10.10.22.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 description WAN SURABAYA TO JAKARTA
 ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet5/0
 description WAN SURABAYA TO MATARAM
 ip address 192.168.2.1 255.255.255.252
!
ip classless
ip route 10.10.11.0 255.255.255.0 192.168.1.1
ip route 10.10.33.0 255.255.255.0 192.168.2.2
ip route 10.10.44.0 255.255.255.0 192.168.2.2
ip route 10.10.55.0 255.255.255.0 192.168.2.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
End

ROUTER MTR
ROUTER-MTR#SH RUN
Building configuration...

Current configuration : 1189 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-MTR
!
!
!
!
!
ip dhcp pool lanmtr1
 network 10.10.33.0 255.255.255.0
 default-router 10.10.33.1
 dns-server 10.10.33.1
ip dhcp pool lanmtr2
 network 10.10.44.0 255.255.255.0
 default-router 10.10.44.1
 dns-server 10.10.44.1
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN MATARAM 1
 ip address 10.10.33.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description LAN MATARAM 2
 ip address 10.10.44.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 description WAN MATARAM TO MALUK
 ip address 192.168.3.1 255.255.255.252
!
interface FastEthernet5/0
 description WAN MATARAM TO SURABAYA
 ip address 192.168.2.2 255.255.255.252
!
ip classless
ip route 10.10.55.0 255.255.255.0 FastEthernet4/0
ip route 10.10.22.0 255.255.255.0 FastEthernet5/0
ip route 10.10.11.0 255.255.255.0 192.168.2.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
End

ROUTER MLK
ROUTER-MLK#sh run
Building configuration...

Current configuration : 1052 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-MLK
!
!
!
!
!
ip dhcp pool Lan-Maluk
 network 10.10.55.0 255.255.255.0
 default-router 10.10.55.1
 dns-server 10.10.55.1
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN MALUK
 ip address 10.10.55.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 description WAN MALUK TO MATARAM
 ip address 192.168.3.2 255.255.255.252
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 10.10.11.0 255.255.255.0 192.168.3.1
ip route 10.10.22.0 255.255.255.0 192.168.3.1
ip route 10.10.33.0 255.255.255.0 192.168.3.1
ip route 10.10.44.0 255.255.255.0 192.168.3.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
End

Kalau sudah semuanya ok, saatnya untuk ditest, dengan perintah ping dari dan ke salah satu komputer. Misalnya dari komputer 10.10.11.3, melakukan ping ke 10.10.55.1. Hasilnya seperti gambar di bawah ini.
Ping ke salah satu komputer

Lakukan juga dari komputer lainnya, ping ke network lainnya. Jika semua hasilnya reply, artinya semua komputer berhasil dikoneksikan dengan menggunakan routing static.

No comments:

Post a Comment