Sunday, February 09, 2014

Packet Tracer Scenario : Virtual LAN ( part 2 )

Eksperiment 2
Percobaan berikutnya, komputer antar vlan, bisa saling berkomunikasi. Jadi tidak ada isolasi antar vlan, tapi menghubungkan network antar vlan. Untuk melakukan hal tersebut, diperlukan sebuah router. Dari segi keamanan, kurang bagus dibandingkan dengan eksperiment yang pertama, karena, semua komputer akan bisa saling berkomunikasi. Jadi tergantung pilihan anda dalam menentukan network mana yang cocok dengan kondisi anda di lapangan.


Konfigurasi Switch 0 / SW-LANTAI-3
SW-LANTAI-3#config ter
SW-LANTAI-3(config)#inter fa4/1
SW-LANTAI-3(config-if)#switchport mode trunk

Konfigurasi Router
Router>en
Router#config ter
Router(config)#inter fa4/0
Router(config-if)#no shut
Router(config-if)#inter fa4/0.11
Router(config-subif)#encapsulation dot1Q 11
Router(config-subif)#ip address 192.168.11.254 255.255.255.0
Router(config-subif)#des GATEWAY VLAN 11
Router(config-subif)#inter fa4/0.12
Router(config-subif)#encapsulation dot1Q 12
Router(config-subif)#ip address 192.168.12.254 255.255.255.0
Router(config-subif)#des GATEWAY VLAN 12
Router(config-subif)#inter fa4/0.13
Router(config-subif)#encapsulation dot1Q 13
Router(config-subif)#ip address 10.13.13.254 255.255.255.0
Router(config-subif)#des GATEWAY VLAN 13
Router(config-subif)#

Pengetestan
Sekarang dari command prompt komputer PC3, melakukan ping ke komputer lainnya. Hasilnya seperti pada gambar di bawah ini. Dari PC3, bisa melakukan ping ke PC1 yang berbeda vlan. Begitu juga dengan PC lainnya, pastinya akan bisa ping ke PC lainnya, walaupun berbeda vlan. Eksperiment 2, sukses.


Eksperiment 3.
Cara lain, untuk membuat inter – vlan, yaitu dengan menggunakan Multilayer switch 3560 series. Jadi, router dan switch di lantai 3 seperti pada eksperiment kedua, dapat saya ganti dengan menggunakan multilayer switch 3560.


Konfigurasi Switch 3560.
Switch>en
Switch#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)# hostname SW-CORE-LANTAI-3
SW-CORE-LANTAI-3(config)#vlan 11
SW-CORE-LANTAI-3(config-vlan)#name manager
SW-CORE-LANTAI-3(config-vlan)#vlan 12
SW-CORE-LANTAI-3(config-vlan)#name staff
SW-CORE-LANTAI-3(config-vlan)#vlan 13
SW-CORE-LANTAI-3(config-vlan)#name helpdesk
SW-CORE-LANTAI-3(config-if)#inter fa0/2
SW-CORE-LANTAI-3(config-if)#switchport access vlan 11
SW-CORE-LANTAI-3(config-if)#desc PORT PC0 Manager
SW-CORE-LANTAI-3(config-if)#inter fa0/3
SW-CORE-LANTAI-3(config-if)#switchport access vlan 12
SW-CORE-LANTAI-3(config-if)#desc PORT PC1 Staff
SW-CORE-LANTAI-3(config-if)#inter fa0/4
SW-CORE-LANTAI-3(config-if)#switchport access vlan 13
SW-CORE-LANTAI-3(config-if)#desc PORT PC2 Helpdesk

Buat konfigurasi interface dari masing-masing vlan
SW-CORE-LANTAI-3(config-if)#inter vlan 11
SW-CORE-LANTAI-3(config-if)#ip address 192.168.11.254 255.255.255.0
SW-CORE-LANTAI-3(config-if)#inter vlan 12
SW-CORE-LANTAI-3(config-if)#ip address 192.168.12.254 255.255.255.0
SW-CORE-LANTAI-3(config-if)#inter vlan 13
SW-CORE-LANTAI-3(config-if)#ip address 10.13.13.254 255.255.255.0

Bisa juga buat IP dhcp servernya.
SW-CORE-LANTAI-3(config)#ip dhcp excluded-address 192.168.11.254
SW-CORE-LANTAI-3(config)#ip dhcp pool vlan11
SW-CORE-LANTAI-3(dhcp-config)#network 192.168.11.0 255.255.255.0
SW-CORE-LANTAI-3(dhcp-config)#default-router 192.168.11.254

Aktifkan routing, agar antar vlan bisa saling berkomunikasi.
SW-CORE-LANTAI-3(config)#ip routing

Pengetestan
Kembali dilakukan pengetestan. Misalnya, dari PC3 melakukan ping ke PC1, yang menggunakan vlan yang berbeda. Hasilnya reply. Begitu juga dengan PC-PC lainnya, tentunya akan bisa ping dan saling berkomunikasi dengan PC lainnya, yang sama ataupun berbeda vlannya.


Eksperiment 4
VTP ( Virtual Trunking Protocol ), gunanya untuk mempermudah dalam pembuatan vlan. Jika mempunyai banyak switch, kita tidak perlu memasukkan satu persatu, nama-nama vlan, ke semua switch. Cukup dibuat 1 server (istilahnya Server VTP) , berisi database semua vlan. Sedangkan switch yang lain, dijadikan client, dimana database vlan akan ditransfer ke semua client.

VTP ada 3 mode, yaitu
  1. Server = create, delete, modify vlan
  2. Client = menerima konfigurasi vlan dan diterapkan atau disimpan vlan tersebut ke diri sendiri
  3. Transparent = menerima konfigurasi dan diteruskan ke switch lain tanpa menerapkan ke diri sendiri.
vtp domain, domain harus sama agar bisa connect
vtp password, untuk keamanan
vtp version, versi terakhir adalah versi 3, namun biasanya cukup gunakan versi ke-2

Perlu ditentukan yang mana vtp server, vtp transparent dan yang mana vtp client. Misalnya.
  • vtp server : sw-lantai -1.
  • vtp transparent : sw-lantai-2
  • vtp client : sw-core-lantai-3.
Konfigurasi Switch SW-LANTAI-1
SW-LANTAI-1>en
SW-LANTAI-1#config ter
SW-LANTAI-1(config)#vtp
SW-LANTAI-1(config)#vtp mode server
SW-LANTAI-1(config)#vtp version 2
SW-LANTAI-1(config)#vtp domain ngeri.com
SW-LANTAI-1(config)#vtp password 123

Konfigurasi Switch SW-LANTAI-2
SW-LANTAI-2>en
SW-LANTAI-2#config ter
SW-LANTAI-2(config)#vtp mode transparent
SW-LANTAI-2(config)#vtp version 2
SW-LANTAI-2(config)#vtp dom ngeri.com
SW-LANTAI-2(config)#vtp password 123

Konfigurasi Switch SW-CORE-LANTAI-3
SW-CORE-LANTAI-3#config ter
SW-CORE-LANTAI-3(config)#vtp mode client
SW-CORE-LANTAI-3(config)#vtp version 2
SW-CORE-LANTAI-3(config)#vtp domain ngeri.com
SW-CORE-LANTAI-3(config)#vtp password 123

Pengetestan
Saatnya untuk pengetestan. Tambahkan beberapa nomor dan nama vlan pada VTP Server (switch SW-LANTAI-1).
SW-LANTAI-1>en
SW-LANTAI-1#config ter
SW-LANTAI-1(config)#vlan 14
SW-LANTAI-1(config-vlan)#name IT
SW-LANTAI-1(config-vlan)#vlan 15
SW-LANTAI-1(config-vlan)#name scurity
SW-LANTAI-1(config-vlan)#vlan 16
SW-LANTAI-1(config-vlan)#name admin

Lihat status vlan pada switch SW-LANTAI-1
SW-LANTAI-1(config-vlan)#do sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa4/1, Fa5/1
11   manager                          active    Fa1/1
12   staff                            active    Fa2/1
13   helpdesk                         active    Fa3/1
14   IT                               active   
15   scurity                          active   
16   admin                            active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Sekarang cek kembali pada switch SW-CORE-LANTAI-3
SW-CORE-LANTAI-3>en
SW-CORE-LANTAI-3#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig0/1, Gig0/2
11   manager                          active    Fa0/2
12   staff                            active    Fa0/3
13   helpdesk                         active    Fa0/4
14   IT                               active   
15   scurity                          active   
16   admin                            active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Ternyata, pada SW-CORE-LANTAI-3, sudah langsung ada vlan baru. Keren bukan … ?? :). Eksperiment 4, sukses dilakukan.

Eksperiment 5
Biasanya untuk memanage switch dari network (secara remote), digunakanlah vlan 1. Kenapa ? karena secara default di semua switch pasti sudah tersedia vlan 1. Pastikan terlebih dahulu, tujuan atau perencanaan network anda. Vlan 1, nantinya apakah bisa diakses dari vlan manapun (tentunya security kurang), ataukah vlan 1, hanya bisa diakses dari vlan 1 – nya saja (security lebih baik. Untuk tujuan seperti ini harus dibuat access list atau ip routingnya dihilangkan ). Dalam eksperiment yang ke-5 ini, semua vlan bisa mengakses vlan 1. Berikut konfigurasi IP address untuk management Switch.

Konfigurasi switch SW-CORE-LANTAI-3
SW-CORE-LANTAI-3#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
SW-CORE-LANTAI-3(config)#inter vlan 1
SW-CORE-LANTAI-3(config-if)#ip address 10.1.1.1 255.255.255.0
SW-CORE-LANTAI-3(config-if)#no shut
SW-CORE-LANTAI-3(config-if)#exit

Konfigurasi line vty agar bisa di-telnet ( diremote )
SW-CORE-LANTAI-3(config)#line vty 0 4
SW-CORE-LANTAI-3(config)#password ngeri
SW-CORE-LANTAI-3(config-line)#login
SW-CORE-LANTAI-3(config-line)#


Konfigurasi switch SW- LANTAI-2
SW-LANTAI-2>en
SW-LANTAI-2#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
SW-LANTAI-2(config)#inter vlan 1
SW-LANTAI-2(config-if)#ip address 10.1.1.2 255.255.255.0
SW-LANTAI-2(config-if)#no shut
SW-LANTAI-2(config-if)#exit
SW-LANTAI-2(config)#ip default-gateway 10.1.1.1

Konfigurasi line vty agar bisa di-telnet ( diremote )
SW-LANTAI-2(config)#line vty 0 4
SW-LANTAI-2(config)#password ngeri
SW-LANTAI-2(config-line)#login
SW-LANTAI-2(config-line)#

Pengetestan
Dari PC6 ping dan telnet ke IP 10.1.1.1 (IP management switch core lantai 3). Hasilnya bisa dilihat pada gambar di bawah ini. Artinya eksperiment 5, berhasil.


Selanjutnya…. Selesai…

1 comment: