Tuesday, May 05, 2015

Simulasi Network Frame Relay di GNS3

Frame Relay Network Simulation

Teknologi Frame Relay sudah mulai ditinggalkan ISP. Mereka kemudian beralih ke teknologi MPLS. Namun karena masih dibahas di CCNA, ya harus tetap dipelajari. :) Sebelum ke konfigurasi, perlu diketahui beberapa hal dan istilah berikut ini.
  • Kabel DTE (Data Terminal Equipment), yang berada di Router.
  • Kabel DCE (Data Circuit-terminating Equipment), yang berada di modem ISP. CMIIW.
  • DLCI (Data Link Control Identifier),  ada di lokasi MDF ISP dalam bentuk krone. Tempat penomoran jaringan akses-nya, seperti itulah kira-kira :).
  • lmi-type, option konfigurasi. Ada 3 type lmi, yaitu Cisco, ANSI dan Q933A. Jika tidak ditentukan, defaultnya tersetting Cisco.
  • Setting clock rate tergantung dari ISP. Jika di ISP sudah disetting clock rate (artinya interface router ISP sebagai DCE), maka di router user tidak perlu disetting (bertindak sebagai DTE). Dan sebaliknya.
  • frame-relay intf-type, ini option juga, untuk menentukan router sebagai DCE ataukah DTE.
  • Virtual connection (VC) adalah jalur yang menghubungkan 2 buah end-user dalam jaringan frame relay. Ada 2 macam yaitu Switched Virtual Connection (SVC) dan Permanent Virtual Connection (PVC)

Ok. network simulasi seperti pada gambar di atas. Masih sangat sederhana. Kemudian settingan Frame relay switch-nya, seperti pada gambar di bawah ini.
Frame Relay Switch Group Configuration

Konfigurasi router R1-JKT
R1-JKT#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R1-JKT(config)#inter fa0/0
R1-JKT(config-if)#ip address 192.168.1.1 255.255.255.0
R1-JKT(config-if)#desc ##LAN##
R1-JKT(config-if)#no shut
R1-JKT(config-if)#inter se0/0
R1-JKT(config-if)#ip add 10.13.13.1 255.255.255.252
R1-JKT(config-if)#desc ##WAN-R1-JKT-TO-R3-MKS##
R1-JKT(config-if)#encapsulation frame-relay
R1-JKT(config-if)#no shut
R1-JKT(config-if)#do wr
Building configuration...
[OK]
R1-JKT(config-if)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

Konfigurasi router R3-MKS
R3-MKS#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3-MKS(config)#inter fa0/0
R3-MKS(config-if)#ip address 192.168.3.1 255.255.255.0
R3-MKS(config-if)#desc ##LAN##
R3-MKS(config-if)#no shut
R3-MKS(config-if)#inter se0/0
R3-MKS(config-if)#ip address 10.13.13.2 255.255.255.252
R3-MKS(config-if)#desc ##WAN-R3-MKS-TO-R1-JKT##
R3-MKS(config-if)#encapsulation frame-relay
R3-MKS(config-if)#no shut
R3-MKS(config-if)#do wr
Building configuration...
[OK]
R3-MKS(config-if)#do copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

Untuk melihat status frame relay mapping addressnya, gunakan command “show frame-relay map”.
R3-MKS#sh frame-relay map
Serial0/0 (up): ip 10.13.13.1 dlci 233(0xE9,0x3890), dynamic,
              broadcast,, status defined, active

Sedangkan dari sisi router R1-JKT,
R1-JKT#sh frame-relay map
Serial0/0 (up): ip 10.13.13.2 dlci 203(0xCB,0x30B0), dynamic,
              broadcast,, status defined, active
R1-JKT#sh ip arp  serial0/0

R1-JKT#
R1-JKT#ping 10.13.13.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.13.13.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/29/72 ms

Ini frame relay ya... jadi tidak keliatan arp-nya. Hanya bisa langsung ping saja. :) CMIIW.
Dan terakhir tambahkan routing staticnya, di sisi router R1-JKT
 R1-JKT(config)#ip route 192.168.3.0 255.255.255.0 10.13.13.2

Juga di sisi router R3-MKS, dan lakukan test ping.
R3-MKS(config)#ip route 192.168.1.0 255.255.255.0 10.13.13.1
R3-MKS#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/42/64 ms

Berhasil. Selanjutnya test ping dari PC1, seharusnya juga berhasil.
Ping from PC1

Noted:
  • Jika network frame relay baru di-UP-kan, agak lumayan lama mikirnya... jadi harus sabar sedikit.
  • (Curhat ma...) Saya sendiri tidak sempat melihat konfigurasi real frame relay di router ISP. Padahal dulu udah di depan mata, tinggal klik-klik sedikit keliatan dah. Tapi itu tidak saya hiraukan karena belum saya pelajari. Sekarang sedang dipelajari, malah udah hilang... Hiks.. hanya terlambat sedikit saja. Memang, penyesalan selalu datang terlambat. :( Jadi, kemungkinan besar banyak yang kurang tepat saat saya membahas frame relay ini. Tolong dikoreksi ya...

No comments:

Post a Comment