Saturday, December 12, 2015

Simulasi Network Frame Relay (Konfigurasi Subinterface Cisco)

Ternyata ada postingan yang masih nyangkut, belum dipublish... :)



 Router
S0/0
S0/1
Fa0/0
Fa1/0
Loopback0
R1-JKT
10.124.124.1/29
10.13.13.1/30

192.168.1.1/24
1.1.1.1/32
R2-SBY
10.124.124.2/29

10.23.23.1/30
192.168.2.1/24
2.2.2.2/32
R3-MKS

10.13.13.2/30
10.23.23.2/30

3.3.3.3/32
R4-MTR
10.124.124.3/29


192.168.4.1/24
4.4.4.4/32


 Kita coba jurus lain, yaitu dengan mengkonfigurasi subinterface Cisco. Design network seperti pada gambar di atas. Begitu juga dengan IP addressnya seperti pada table. Keliatan dari designnya ribet sekali. Tapi sebenarnya masih sederhana.



Konfigurasi Router Cisco R1-JKT.
R1-JKT#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R1-JKT(config)#inter s0/1
R1-JKT(config-if)#desc ##CONNECT-TO-R3-MKS##
R1-JKT(config-if)#encapsulation frame-relay
R1-JKT(config-if)#no shut
R1-JKT(config-if)#inter s0/1.13 point-to-point
R1-JKT(config-subif)#ip address 10.13.13.1 255.255.255.252
R1-JKT(config-subif)#frame-relay interface-dlci 101

Router Cisco R3-MKS
R3-MKS#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3-MKS(config)#inter se0/1
R3-MKS(config-if)#desc ##CONNECT-TO-R1-JKT##
R3-MKS(config-if)#encapsulation frame-relay
R3-MKS(config-if)#no shut
R3-MKS(config-if)#inter se0/1.13 point-to
R3-MKS(config-subif)#ip add 10.13.13.2 255.255.255.252
R3-MKS(config-subif)#frame-relay interface-dlci 301

Router R1-JKT di interface serial 0/1 dan R3-MKS interface serial 0/1, dibuat sub interface point-to-point. Seperti konfigurasi di atas. Dan keduanya seharusnya akan bisa saling berkomunikasi (ping).

Selanjutnya konfigurasi router Cisco R1-JKT, interface serial 0/0 multipoint.
R1-JKT#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R1-JKT(config)#inter se0/0
R1-JKT(config-if)#desc ##BACKHOUL##
R1-JKT(config-if)#encapsulation frame-relay
R1-JKT(config-if)#no shut
R1-JKT(config-if)#inter se0/0.124 multipo
R1-JKT(config-subif)#ip add 10.124.124.1 255.255.255.248
R1-JKT(config-subif)#frame-relay interface-dlci 111
R1-JKT(config-subif)#frame-relay interface-dlci 112

Sedangkan di router R2-SBY, interface serial 0/0 multipoint.
R2-SBY#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R2-SBY(config)#inter se0/0
R2-SBY(config-if)#encaps frame-re
R2-SBY(config-if)#desc ##CONNECT-TO-BACKHOUL##
R2-SBY(config-if)#no shut
R2-SBY(config-if)#inter se0/0.221 multipoint
R2-SBY(config-subif)#ip add 10.124.124.2 255.255.255.248
R2-SBY(config-subif)#frame-relay inter 221
R2-SBY(config-subif)#frame-relay inter 222

Selanjutnya kita setting router R4-MTR, interface serial 0/0 multipoint juga
R4-MTR#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4-MTR(config)#inter se0/0
R4-MTR(config-if)#encaps frame
R4-MTR(config-if)#desc ##CONNECT-TO-BACKHOUL##
R4-MTR(config-if)#no shut
R4-MTR(config-if)#inter se0/0.44 multipoint
R4-MTR(config-subif)#ip add 10.124.124.3 255.255.255.248
R4-MTR(config-subif)#frame-relay interface-dlci 441
R4-MTR(config-subif)#frame-relay interface-dlci 442

Kalo misalnya R4-MTR disetting point to point, bagaimana ? sehingga point to point ketemu dengan multipoint.
Dicoba dalam lab  ini sih, bisa saja satunya multipoint terhubung ke point to point... tapi kadang ngehang juga :). Lebih baik dihindari saja. Ingat ini... Saat implementasi realnya, jangan pernah membuat sesuatu yag aneh-aneh, bikin ribet dan mumet. Kalo ada mudahnya, pakai yang mudahnya saja, yang terpenting sesuai dengan aturan. Jika menggunakan multipoint semua multipoint. Jika point to point semuanya juga disetting point to point. CMIIW.

Mari kita test ping dari salah satu router saja. Misalnya dari router R4-MTR.
R4-MTR#sh frame-relay map
Serial0/0.44 (up): ip 10.124.124.1 dlci 441(0x1B9,0x6C90), dynamic,
              broadcast,
              CISCO, status defined, active
Serial0/0.44 (up): ip 10.124.124.2 dlci 442(0x1BA,0x6CA0), dynamic,
              broadcast,, status defined, active

R4-MTR#ping 10.124.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.124.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/55/117 ms
R4-MTR#ping 10.124.124.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.124.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/49/181 ms

Beres...  Selanjutnya, agar semua network bisa berkomunikasi, gunakan saja routing ospf. Berikut konfigurasinya, ( pembahasannya dipercepat saja karena sudah pernah dibahas..)

Router R1
R1-JKT#config ter
R1-JKT(config)#inter loo
R1-JKT(config)#inter loopback 0
R1-JKT(config-if)#ip add 1.1.1.1 255.255.255.255
R1-JKT(config-if)#inter fa1/0
R1-JKT(config-if)#ip add 192.168.1.1 255.255.255.0
R1-JKT(config-if)#desc ##LAN##
R1-JKT(config-if)#no shut
R1-JKT(config-if)#exit
R1-JKT(config)#router ospf 1
R1-JKT(config-router)#netw 1.1.1.1 0.0.0.0 area 0
R1-JKT(config-router)#netw 192.168.1.0 0.0.0.255 area 0
R1-JKT(config-router)#netw 10.13.13.0 0.0.0.3 area 0
R1-JKT(config-router)#netw 10.124.124.0 0.0.0.7 area 0

Router R2-SBY
R2-SBY#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R2-SBY(config)#inter f0/0
R2-SBY(config-if)#desc ##P2P TO R3-MKS##
R2-SBY(config-if)#ip add 10.23.23.1 255.255.255.252
R2-SBY(config-if)#no shut
R2-SBY(config-if)#inter fa1/0
R2-SBY(config-if)#ip add 192.168.2.1 255.255.255.0
R2-SBY(config-if)#desc ##LAN##
R2-SBY(config-if)#no shut
R2-SBY(config-if)#inter loopback0
R2-SBY(config-if)#ip add 2.2.2.2 255.255.255.255
R2-SBY(config-if)#exit
R2-SBY(config)#router ospf 2
R2-SBY(config-router)#netw 10.124.124.0 0.0.0.7 area 0
R2-SBY(config-router)#netw 10.23.23.0 0.0.0.3 area 0
R2-SBY(config-router)#netw 192.168.2.0 0.0.0.255 area 0
R2-SBY(config-router)#netw 2.2.2.2 0.0.0.0 area 0

Router R3
R3-MKS#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3-MKS(config)#inter fa0/0
R3-MKS(config-if)#ip add 10.23.23.2 255.255.255.252
R3-MKS(config-if)#no shut
R3-MKS(config-if)#desc ##P2P TO R2-SBY##
R3-MKS(config-if)#inter loopback0
R3-MKS(config-if)#ip add 3.3.3.3 255.255.255.255
R3-MKS(config-if)#exit
R3-MKS(config)#router ospf 3
R3-MKS(config-router)#netwo 10.23.23.0 0.0.0.3 area 0
R3-MKS(config-router)#netwo 3.3.3.3 0.0.0.0 area 0
R3-MKS(config-router)#netwo 10.13.13.0 0.0.0.3 area 0

Router R4
R4-MTR#config ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4-MTR(config)#inter fa1/0
R4-MTR(config-if)#desc ##LAN##
R4-MTR(config-if)#ip add 192.168.4.1 255.255.255.0
R4-MTR(config-if)#no shut
R4-MTR(config-if)#inter loopback0
R4-MTR(config-if)#ip add 4.4.4.4 255.255.255.255
R4-MTR(config-if)#exit
R4-MTR(config)#router ospf 4
R4-MTR(config-router)#netw 192.168.4.0 0.0.0.255 area 0
R4-MTR(config-router)#netw 10.124.124.0 0.0.0.7 area 0
R4-MTR(config-router)#netw 4.4.4.4 0.0.0.0 area 0

Dan berikut hasil sh ip route dari salah satu router, yang menandakan router ospf running.
R4-MTR#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 10.124.124.1, 00:09:48, Serial0/0.44
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 10.124.124.2, 00:09:48, Serial0/0.44
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/75] via 10.124.124.2, 00:09:48, Serial0/0.44
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
C    192.168.4.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.124.124.0/29 is directly connected, Serial0/0.44
O       10.23.23.0/30 [110/74] via 10.124.124.2, 00:09:50, Serial0/0.44
O       10.13.13.0/30 [110/128] via 10.124.124.1, 00:09:50, Serial0/0.44
O    192.168.1.0/24 [110/65] via 10.124.124.1, 00:09:51, Serial0/0.44
O    192.168.2.0/24 [110/65] via 10.124.124.2, 00:09:51, Serial0/0.44

Yang perlu diingat.

  1. Nomor sub interface, boleh berapa saja. Tapi biasanya, supaya tidak lupa, bisa berdasarkan nomer dlci, dan disamakan saja kedua antar interface.
  2. Dengan menggunakan multipoint, maka akan mendapatkan dynamic ip address dan dlci. Dan memakan waktu yang agak lama untuk mendeteksinya.
  3. Jika multipoint, cukup 1 sub interface ke semua jalur ( itu berarti hanya ada 1 ip address). Sedangkan  point to point, setiap 1 jalur = 1 interface = 1 ip address ( itu berarti akan banyak IP address, tergantung dari jumlah jalur).
  4. Biasanya ospf akan langsung up, tapi jika memang diperlukan pada settingan ospf tambahkan command neigboar untuk menspesifikasikan neigbornya.

2 comments:

  1. terimakasih banyak ilmunya gan :)
    http://www.anditii.web.id

    ReplyDelete
  2. Sedikit masukan Om, kira2 kalau nomor DLCI disesuaikan sm nama Router gmna?

    Misal :
    R1 ke R2 pakai 102
    R1 ke R4 pakai 104
    R2 ke R4 pakai 204, dst.


    Kli aja lebih gampang di mengerti sm pembaca ^_^

    Regards,
    BSA

    ReplyDelete